+ Reply to Thread
Results 1 to 7 of 7

Thread: vBulletin 4.xx, Stop Attachments Getting Deleted - the Invalid Attachment Problem

  1. #1
    Top Contributor
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    919
    Thanks
    2,027
    Thanked 1,476 Times in 709 Posts
    Rep Power
    42

    vBulletin 4.xx, Stop Attachments Getting Deleted - the Invalid Attachment Problem

    Adding Attachments to vBulletin Posts

    Experienced-People.net (EP) is a vBulletin (vB) discussion forum. vB allows attachments to posts. This includes images (with any of 7 file extensions), as well as several other file types. Maximum file size on EP is 100K. Allowed file types are bmp, doc, docx, gif, jpe, jpeg, jpg, pdf, png, psd, txt, xls, xlsx, zip.

    vB provides two methods for attaching a file to a post (through three different actions). Please be aware that one method works consistently, and the other has had ongoing problems (causing vB boards to purge attachments).

    In brief, if you are adding an attachment to a post, click on the Go Advanced button shown under the Quick Reply post entry area. Do not use the Insert Image icon shown at the top of the Quick Reply area, also shown at the top of the post area when clicking on Edit Post.

    If your attachment is a graphic and is displayed in your post as a graphic, you have added it correctly. If you have attached another files type, such as a spreadsheet or Zip file, the name of the file should be shown.

    If your attachment appears similar to the following text, such as:

    Attachment 400

    you will need to edit your post. Any attachments displayed in a post with the word, Attachment, followed by a number, have not been added to a post.

    Attachments not used in a post are purged by vB after one hour; Your attachment must be displayed within your post (either as the graphic for images, or the file name for other file type attachments) to prevent vB from removing it.

    This is all the information needed (if you are familiar with vB use) for permanent attachments. Greater detail is below.
    Last edited by Kay; 10 April 2014 at 8:33 pm. Reason: Promoted to sticky

  2. The Following 2 Users Say Thank You to KenW3 For This Useful Post:

    Kay (10 April 2014), TheodoreK (20 September 2012)

  3. #2
    Top Contributor
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    919
    Thanks
    2,027
    Thanked 1,476 Times in 709 Posts
    Rep Power
    42

    Adding attachments process

    The correct button to use when adding attachments in vB is below the post entry area (for both the Go Advanced entry screen and the Edit Post entry page), and is named Manage Attachments.
    Manage Attachments 150.JPG
    There are two ways to access this tool when making posts to vB. Clicking on 'Go Advanced' to make a post will enable access to the tool. After a post has been made, clicking on Edit Post will also give you access to the tool.

    To add a file:
    1. Click on Manage Attachments.
    2. Click on +Add Files (in the upper right). A dialog allowing you to Select Files is shown.
    3. Clicking on Select Files to show files on your computer.
    3a. Clicking on Basic Uploader, then Browse, will also allow selection of a file from your computer.
    4. Navigate to the directory holding the file you wish to attach
    5. Click once to highlight and then click on Open (or double-click the file).
    5a. This will show the file name in your Upload Files dialog.
    6. Click on Upload Files to add the file to your File Upload manager under Attachments.
    7. In the lower attachments area, the file should be accompanied by a tick in a box. If not, add check in lower right corner of attachment and click on Insert Inline.
    8. Click on Done to complete the process, and close the tool.

    Your attachment will be placed wherever your cursor was placed (in your post) when you entered this Manage Attachments tool. (Position can be changed by moving the vB ATTACH code.)

    (Please also be aware that this tool does not allow files to be stored for future use. Uploads not utilized within one hour will be deleted. Uploads that are not stored properly are also deleted within an hour.)

  4. #3
    Top Contributor
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    919
    Thanks
    2,027
    Thanked 1,476 Times in 709 Posts
    Rep Power
    42

    Further Details

    Post area icons which allow enhanced posts

    The Quick Reply area at the bottom of each thread has a number of icons shown which are used to make an enhanced post. This set of icons starts with an A/A which is used to turn WYSIWYG visual mode (source editor) on and off. Additional icons are used to for text bold, italics, or underlined text. Further to the right is an icon for Insert Image (just to the right of Insert Link and Remove Link).

    Do not use this icon to insert an image into vB.

    Yes, Clicking on it will provide an Insert Image tool to upload a file from your computer. It states allowed file types of jpg, jpeg, png, gif (which are 4 of the 7 graphics types allowed under Manage Attachments). Clicking on From Computer and then clicking on Select Files and Upload File(s) will allow you to add files to your attachments. These can be seen under Settings > My Settings > Miscellaneous > Attachments but vB sometimes purges these for some reason.

    If you see this upload dialog,

    Insert Image dialog.jpg

    Close it and go to the Manage Attachments tool.



    Viewing your stored attachments through your member Settings page

    At the top of every page, at the upper right within the browser window, is a clickable link named Settings (just to the left of the Log Out link). Once you click on the link, the left side will show your membership options. After you have clicked on Settings, go to My Settings (shown on the left side of the page) and scroll down to General Settings (under My Account). Click on Attachments.

    This is one of two areas on vB where your member attachments can be viewed. The other area is available when using the Manage Attachments tool referenced above.

    If your attachment is shown in these areas, then it has been uploaded to the vB database. This 'does not' mean that it will remain on vB permanently. It will only remain as an attachment if it has been used in a post. If your upload is not being displayed in your post, and the post states the word, Attachment (followed by a number), then the attachment has -not- been used in a post (as 'Attachment xxx' is not your attachment). If you have use the Manage Attachments tool to add the graphic directly to the database, and have used it in a post, it will remain.



    Changing your preferred vB Editor Interface

    If you are adding attachments, please make certain your posting preference is set to Enhanced Editor.

    Follow the same process as described above to get to your options. Once you have gone to Settings, click on General Settings, scroll down to Miscellaneous Options. The first option is the Message Editor Interface. This provides three selections
    • Enhanced Interface - Full WYSIWYG Editing
    • Basic Editor - A simple text box
    • Standard Editor - Extra formatting controls
    Both Standard Editor and Enhanced Editor provide editing icons at the top of the Quick Reply post entry area, and when clicking on Edit Post. If you do not have these icons at the top of your text editing area and at the top of the Quick Reply text entry area, then you have Basic Editor enabled. (Selection of Enhanced Interface is recommended.)

  5. #4
    Top Contributor
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    919
    Thanks
    2,027
    Thanked 1,476 Times in 709 Posts
    Rep Power
    42

    Epilogue

    Post 1 is the information. Posts 2 and 3 are support.

    This thread is the result of members losing attachments in vBulletin. Every member I have dealt with that has lost an attachment... Every post I have edited to add back an attachment... Everything I have read on other sites regarding loss of attachment... All attachments which have been purged from the vB database have been a result of using the WYSIWYG posting interface to add an attachment. I have lost attachments myself, but have never lost one posted through the use of the Manage Attachments tool.

    Attachments are lost when members use the Insert Image tool above the post area. Posts through both the Enhanced Editor setting and the Standard Editor setting, coupled with this Insert Image tool, result in lost attachments. I have had the Insert Image tool work intermittently when member settings are to Enhanced Editor, which is why the OP recommends that members always us the Manage Attachments tool. (In the case of a Basic Editor setting, the Insert Image icon is not visible.)

    Please be aware that the above has not been tested across all browsers.

    As this may be of use to other vB admins, permission is given to reproduce this thread (or any portion of it) as long as Experienced-People.net is attributed as the source with a link back to this site, under the Creative Commons Attribution 3.0 Unported License

  6. The Following 3 Users Say Thank You to KenW3 For This Useful Post:

    bwelford (20 September 2012), Kay (20 September 2012), monty (20 September 2012)

  7. #5
    Administrator Clinton is a Premium Member
    Join Date
    Jan 2010
    Location
    Essex, UK
    Posts
    7,615
    Blog Entries
    31
    Thanks
    4,228
    Thanked 3,026 Times in 1,683 Posts
    Rep Power
    110
    Wow, thanks Ken. This has been a vB bugbear for a long time. There have been numerous threads in various vBulletin support forums and nobody, it seems, has figured out this problem till now.

    If you don't mind, I'll change the title of the thread to better fit the SE searches people conduct for a solution to this problem. I'll also add a FAQ link to this thread.

    In response to this:

    Follow the same process as described above to get to your options. Once you have gone to Settings, click on General Settings, scroll down to Miscellaneous Options. The first option is the Message Editor Interface. This provides three selections
    Enhanced Interface - Full WYSIWYG Editing
    Basic Editor - A simple text box
    Standard Editor - Extra formatting controls
    For clarity, I'd like to point out that newer users on this forum - less than 50 posts - don't have access to edit settings to change the Message Editor Interface.... but you don't need to worry about this, just follow the instructions in Ken's post #2 if you wish to add an attachment.

    I've promoted this thread to the Frontpage as it is bound to be of help to many. Great job, Ken!
    Find the right business brokers to maximise the value you extract from your business and improve the chances of selling your business.

  8. #6
    Top Contributor
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    919
    Thanks
    2,027
    Thanked 1,476 Times in 709 Posts
    Rep Power
    42
    Quote Originally Posted by Clinton View Post
    If you don't mind, I'll change the title of the thread to better fit the SE searches people conduct for a solution to this problem. I'll also add a FAQ link to this thread.
    You are certainly welcome to change the title. I'll add the original title to the top of the OP in bold.

    The WYSIWYG posting and editing vB UI has had difficulties in the past. This isn't a solution for the bug; It does provide the means by which to add an attachment that won't be purged, with a way to immediately determine when an attachment will be lost due to improper insertion within a post.

  9. #7
    Moderator Kay is a Premium Member
    Join Date
    Sep 2010
    Location
    Kent - the garden of England
    Posts
    6,166
    Blog Entries
    2
    Thanks
    4,297
    Thanked 3,342 Times in 2,133 Posts
    Rep Power
    95
    I'm promoting this to a sticky because the problem still crops up from time to time and this'll save us digging for it again.
    British Expat - helping people to live and work abroad since the year 2000.

    The joy of Internet delivery - the cartoon illustrating this will make you laugh!



  10. The Following 2 Users Say Thank You to Kay For This Useful Post:

    Chabrenas (11 April 2014), JimWaller (11 April 2014)

+ Reply to Thread

Similar Threads

  1. FP - Lost Rank After Adding Content
    By CALLMEBILL in forum SEO & Search Engine News
    Replies: 4
    Last Post: 2 October 2011, 11:15 am
  2. FP - How to vBulletin
    By Dean in forum SEO & Search Engine News
    Replies: 1
    Last Post: 27 January 2011, 2:06 pm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts